有关编译windows下GPU版本gromacs 2018.4的问题



  • 我使用的是VS2017,CUDA版本10.0(低版本的CUDA直接支持不了VS2017),同时mkl库使用的是Intel Parallel Studio XE 2019里面的,cmake使用的是3.13.3, 在使用Cmake进行configure的时候总是提示gmxManageNvccConfig.cmake报错,提示NVCC编译器可能不工作,把这个用2016.5的同文件替换以后Configure成功通过,但是生成的VS2017工程文件怎么着都没法编译,照着网上查到的把源代码里面的static const float改成了static constant float之后也还是不行,代码里面出现了好多被VS标红的语法错误,编译老是通过不了,请问下这是为什么呀?十不是需要把CUDA换成低版本的然后把VS换成2015版的才行啊



  • 不同系列版本的gmx源码不一样,你不能直接替换其文件,得看具体的错误出现在哪里。


Log in to reply
 

Looks like your connection to 分子模拟之道 was lost, please wait while we try to reconnect.